Discussion:
Seagata-Sata in Wechselrahmen langsam
(zu alt für eine Antwort)
Steve Frank
2017-05-06 21:02:58 UTC
Permalink
Raw Message
Hallo NG,

hier soll eine ST31000528AS (1TB) in einem Wechselrahmen zum Einsatz
kommen. Die Platte macht normalerweise beim Lesen ca. 110MB/s (mit
HDDSpeed).
Beim Einbau in den Wechselrahmen (ST135-SATA) macht die Platte plötzlich
nur noch 30MB/s.
Zuerst dachte ich an die SATA-Kabel, dann an die
Wechselrahmenelektronik, alles wurde getauscht und mit anderen Platten
gegengeprüft.
Auch die Platte per Jumper auf max. Anschluß-SATA1 zu zwingen brachte
keinen Erfolg.
Die Anschluß-Daten per Crystal-Disk-Info sehen mit und ohne Wechelrahmen
völlig identisch aus.

Wie könnte man dieser Inkompatibilität auf die Spur kommen?
Marcel Mueller
2017-05-07 05:35:58 UTC
Permalink
Raw Message
Post by Steve Frank
hier soll eine ST31000528AS (1TB) in einem Wechselrahmen zum Einsatz
kommen. Die Platte macht normalerweise beim Lesen ca. 110MB/s (mit
HDDSpeed).
Beim Einbau in den Wechselrahmen (ST135-SATA) macht die Platte plötzlich
nur noch 30MB/s.
Wie könnte man dieser Inkompatibilität auf die Spur kommen?
Gucke mal, ob es viele Retransmissions wegen CRC Fehlern gibt. AFAIK
wird das sowohl vom Host als auch von der Platte in den Smart-Daten
aufgezeichnet.

Wenn ja, kennst Du das Problem: der Wechselrahmen taugt nichts, weil er
die Übertragungsqualität zu sehr stört.


Marcel
Steve Frank
2017-05-07 09:47:23 UTC
Permalink
Raw Message
Post by Marcel Mueller
Post by Steve Frank
hier soll eine ST31000528AS (1TB) in einem Wechselrahmen zum Einsatz
kommen. Die Platte macht normalerweise beim Lesen ca. 110MB/s (mit
HDDSpeed).
Beim Einbau in den Wechselrahmen (ST135-SATA) macht die Platte plötzlich
nur noch 30MB/s.
Wie könnte man dieser Inkompatibilität auf die Spur kommen?
Gucke mal, ob es viele Retransmissions wegen CRC Fehlern gibt. AFAIK
wird das sowohl vom Host als auch von der Platte in den Smart-Daten
aufgezeichnet.
Wenn ja, kennst Du das Problem: der Wechselrahmen taugt nichts, weil er
die Übertragungsqualität zu sehr stört.
Das "Lustige" ist ja, dass die Platte in allen drei vorhandenen
Wechselrahmen gleichen Typs identische Mucken macht, andere Platten
haben in diesen Rahmen keinerlei Probleme und haben (bis auf minimale
Abweichung) vollen Durchsatz als wären sie direkt ohne Rahmen angeschlossen.

Das einzige was ich betr. CRC in den Smartdaten der Platte sehen kann
ist "UltraDMA CRC Error Count" in der Zähler steht auf 0.
Jedoch klettert "Seek Error Rate" sehr fleissig wenn im Rahmen verbaut
(egal welcher von den dreien), direkt angeschlossen steht der Zähler (fast).
Wenn ich SER jedoch richtig deute, dann hat das doch nichts mit der
Schnittstelle an sich zu tun, wundere mich ein wenig, dass die sich mit
Rahmen schneller ändert als ohne.
Marcel Mueller
2017-05-07 11:51:43 UTC
Permalink
Raw Message
Post by Steve Frank
Post by Marcel Mueller
Gucke mal, ob es viele Retransmissions wegen CRC Fehlern gibt. AFAIK
wird das sowohl vom Host als auch von der Platte in den Smart-Daten
aufgezeichnet.
Wenn ja, kennst Du das Problem: der Wechselrahmen taugt nichts, weil
er die Übertragungsqualität zu sehr stört.
Das "Lustige" ist ja, dass die Platte in allen drei vorhandenen
Wechselrahmen gleichen Typs identische Mucken macht, andere Platten
haben in diesen Rahmen keinerlei Probleme und haben (bis auf minimale
Abweichung) vollen Durchsatz als wären sie direkt ohne Rahmen
angeschlossen.
Naja, diesem Plattenmodell gefallen die Rahmen halt nicht.

Btw. wie ist die Platte denn verschraubt? Könnte es ein Problem mit der
Rückstoßenegie bei den Servos sein? Oder eventuell Vibrationen oder
Resonanzen? Besonders schlecht eignen sich No-Vibes Rahmen.
Post by Steve Frank
Das einzige was ich betr. CRC in den Smartdaten der Platte sehen kann
ist "UltraDMA CRC Error Count" in der Zähler steht auf 0.
Dann war es das nicht.
Post by Steve Frank
Jedoch klettert "Seek Error Rate" sehr fleissig wenn im Rahmen verbaut
(egal welcher von den dreien), direkt angeschlossen steht der Zähler (fast).
Aha, dann war es das zweite. Die Rückstoßenegie bzw. eine Resonanz bei
einer (für diese Platte) blöden Frequenz.

Klebe eine möglichst schwere Blei- oder Eisenplatte mit Doppelklebeband
auf das Plattengehäuse, und dann ist Ruhe. Das ist jetzt kein Spaß von
wegen Erdstrahlen oder so, sondern einfach nur Physik.


Marcel
Detlef Wirsing
2017-05-07 12:32:18 UTC
Permalink
Raw Message
[...]
Post by Marcel Mueller
Post by Steve Frank
Jedoch klettert "Seek Error Rate" sehr fleissig wenn im Rahmen verbaut
(egal welcher von den dreien), direkt angeschlossen steht der Zähler (fast).
Aha, dann war es das zweite. Die Rückstoßenegie bzw. eine Resonanz bei
einer (für diese Platte) blöden Frequenz.
Klebe eine möglichst schwere Blei- oder Eisenplatte mit Doppelklebeband
auf das Plattengehäuse, und dann ist Ruhe. Das ist jetzt kein Spaß von
wegen Erdstrahlen oder so, sondern einfach nur Physik.
Ich würde vorher versuchen, die Platte im Wechselrahmen zu betreiben
ohne sie festzuschrauben. Solches Verhalten hatte ich schon mal, wenn
das Gehäuse der Platte durch das Festschrauben und Einsetzen des
Rahmens in den PC (oder beim Direkteinbau in einen Schacht) verzogen
wurde. Da spielen oft kleine Toleranzen schon eine Rolle. Motherboards
(wie Radmuttern) soll man ja auch über Kreuz anziehen und nicht
reihum, um zu Vermeiden, dass das Board hinterher unter Spannung
steht. Auch deswegen hatte ich schon mal Fehler, als ich früher noch
in der Branche gearbeitet habe.

Mit freundlichen Grüßen
Detlef Wirsing
Steve Frank
2017-05-07 22:24:59 UTC
Permalink
Raw Message
[...]
Post by Detlef Wirsing
Post by Marcel Mueller
Klebe eine möglichst schwere Blei- oder Eisenplatte mit Doppelklebeband
auf das Plattengehäuse, und dann ist Ruhe. Das ist jetzt kein Spaß von
wegen Erdstrahlen oder so, sondern einfach nur Physik.
Ich würde vorher versuchen, die Platte im Wechselrahmen zu betreiben
ohne sie festzuschrauben. Solches Verhalten hatte ich schon mal, wenn
das Gehäuse der Platte durch das Festschrauben und Einsetzen des
Rahmens in den PC (oder beim Direkteinbau in einen Schacht) verzogen
wurde. Da spielen oft kleine Toleranzen schon eine Rolle. Motherboards
(wie Radmuttern) soll man ja auch über Kreuz anziehen und nicht
reihum, um zu Vermeiden, dass das Board hinterher unter Spannung
steht. Auch deswegen hatte ich schon mal Fehler, als ich früher noch
in der Branche gearbeitet habe.
Ebenfall mal getestet, keine Besserung, also kein vermuteter "Verzug".
Alternativ mal nur die Wechselrahmenelektronik ausgebaut und
"zwischengeschaltet", der Fehler bleibt.
Steve Frank
2017-05-07 22:22:41 UTC
Permalink
Raw Message
Am 07.05.2017 um 13:51 schrieb Marcel Mueller:
[...]
Post by Marcel Mueller
Aha, dann war es das zweite. Die Rückstoßenegie bzw. eine Resonanz bei
einer (für diese Platte) blöden Frequenz.
Klebe eine möglichst schwere Blei- oder Eisenplatte mit Doppelklebeband
auf das Plattengehäuse, und dann ist Ruhe. Das ist jetzt kein Spaß von
wegen Erdstrahlen oder so, sondern einfach nur Physik.
Danke für den Tip, Platte stand jetzt nicht zur Verfügung, dennoch im
offenen Rahmen (der ausgebaut ist) mal alternativ beschwert, half nicht,
jdeoch nicht geklebt, mal sowas besorgen und dann mal testen.
Steve Frank
2017-05-08 03:22:05 UTC
Permalink
Raw Message
Am 07.05.2017 um 13:51 schrieb Marcel Mueller:
[...]
Post by Marcel Mueller
Klebe eine möglichst schwere Blei- oder Eisenplatte mit Doppelklebeband
auf das Plattengehäuse, und dann ist Ruhe. Das ist jetzt kein Spaß von
wegen Erdstrahlen oder so, sondern einfach nur Physik.
Es war tatsächlich nicht die Physik, sondern schlicht und ergreifend die
Firmware (man glaubt es kaum). Da nichts zu verlieren war, habe ich die
Firmware von CC44 auf CC49 (von der Seagate-Seite) geändert und siehe
da... im Wechselrahmen schnurrt die nun genauso schnell wie ohne. Und
das erkläre mir nunmal einer?!?!?
Bertram Schrahder
2017-05-08 13:21:24 UTC
Permalink
Raw Message
Post by Steve Frank
Hallo NG,
hier soll eine ST31000528AS (1TB) in einem Wechselrahmen zum Einsatz
kommen. Die Platte macht normalerweise beim Lesen ca. 110MB/s (mit
HDDSpeed).
Beim Einbau in den Wechselrahmen (ST135-SATA) macht die Platte plötzlich
nur noch 30MB/s.
Zuerst dachte ich an die SATA-Kabel, dann an die
Wechselrahmenelektronik, alles wurde getauscht und mit anderen Platten
gegengeprüft.
Auch die Platte per Jumper auf max. Anschluß-SATA1 zu zwingen brachte
keinen Erfolg.
Die Anschluß-Daten per Crystal-Disk-Info sehen mit und ohne Wechelrahmen
völlig identisch aus.
Wie könnte man dieser Inkompatibilität auf die Spur kommen?
wasfuer einen sync status bzw link status auf sata ebene kann denn die
platte wenn sie mit und ohne rahmen direkt am controller haengt? das
wuerde ich as erstes feststellen ob der rahmen die platte auf einem
aelteren (s)ata level festpinnt etc

b

Loading...