Discussion:
Kopiergeschwindigkeit bricht ein (Windows 8.1)
(zu alt für eine Antwort)
Detlef Wirsing
2017-08-20 20:21:35 UTC
Permalink
Raw Message
Hallo,

seit 2 Tagen bricht bei mir die Kopiergeschwindigkeit von Platte zu
Platte nach ca. 4 GB ein. Das ist der Wert, in dem der Cache noch
greift. Ab da habe ich statt der sonst üblichen 110 MB/s nur noch
gleichbleibende 18. Das verwundert mich vor allem deshalb, weil ich
gerade erst ca. 20 TB an Daten bei voller Geschwindigkeit verschoben
habe. Controller ist ein Intel C220 on Board mit AHCI.

Mir fällt auf, dass die AHCI-Treiber des C220 laut Gerätemanager
iastore.sys und iastorf.sys sind. In der Registry unter
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci aber
storahci.sys steht. Könnte es damit zusammenhängen?

Eine Frage zwischen Betriebssystem und Hardware, deshalb der Crosspost
nach de.comp.os.ms-windows.misc mit fup2
de.comp.hardware.laufwerke.festplatten, weil ich dort eher jemanden
erwarte, der sowas schon mal hatte. Alle Controllereinträge im
Gerätemanager deinstallieren und neu starten, der Klassiker also,
brachte keine Änderung.

Mit freundlichen Grüßen
Detlef Wirsing
Marcel Mueller
2017-08-21 02:32:52 UTC
Permalink
Raw Message
Post by Detlef Wirsing
seit 2 Tagen bricht bei mir die Kopiergeschwindigkeit von Platte zu
Platte nach ca. 4 GB ein. Das ist der Wert, in dem der Cache noch
greift. Ab da habe ich statt der sonst üblichen 110 MB/s nur noch
gleichbleibende 18.
Kaufe eine SSD und dein Problem ist vmtl. behoben. ;-)

Aber die Sache mit dem Cache deutet darauf hin, dass es Probleme beim
(gleichzeitigen) Schreiben und nicht beim Lesen gibt.
Post by Detlef Wirsing
Das verwundert mich vor allem deshalb, weil ich
gerade erst ca. 20 TB an Daten bei voller Geschwindigkeit verschoben
habe.
Controller ist ein Intel C220 on Board mit AHCI.
Ich bin mit Intel nicht vertraut, aber ist das zufällig einer der Intel
SATA Controller, die sich nach einiger Zeit selbst desintegrieren? Von
den Symptomen her würde es passen.

Ansonsten hängt es auch stark davon ab, was man für Daten kopiert
(Dateigrößen), wie voll die Zielfestplatte schon ist und mit welchem
Programm kopiert wird.

Auf jeden Fall solltest Du das Thema Hardwareprobleme auch mit in die
Waagschale werfen. SATA Kabel sind bekanntlich immer mal für eine Spaß
zu haben.

Mit Windows Perfmon kann man den Platten man auf den Zahn fühlen.
Interessant sind die Werte Physischer Datenträger: (Milli-)Sekunden pro
Lese- bzw. Schreibvorgang. Das sollte bei Platten zwischen 5 und 20
liegen (und SSDs vernachlässigbar) sein. Signifikant größere Werte
deuten auf Probleme der Platten beim lokalisieren der Spuren - kommt bei
Terabytegräbern leider öfter vor.

Wenn das normal ist, gehört der nächste Blick den Werten mittlere Bytes
pro Lese- bzw. Schreibvorgang. Wenn da beim Kopieren weniger als einige
hundert kB stehen, weißt Du auch, woran es liegt: die Blöcke sind zu
klein und die Platte verbringt die meiste Zeit damit, den Kopf zu
bewegen, statt Daten zu übertragen.
Das kann dann verschiedene Ursachen haben. Fragmentierung ist eine.
Viele kleine Dateien eine andere. Andere Programme, die mit sinnlosen
Zugriffen dazwischengrätschen eine dritte. Jedenfalls wird Deine Platte,
wenn sie z.B. 15ms pro Zugriff braucht, bei 1MB Blockgröße nicht mehr
als 66MB/s stemmen. Falls auf derselben Platte gelesen und geschrieben
wird, nochmal die Hälfte.
Aufpassen mit der Skalierung, der Bytes/IO-Graph kommt zumindest unter
Win7 mit dem sinnlosen Faktor 0,01 = in Einheiten von 100 Bytes. Das
sollte man auf 0,0001 umstellen (Doppelklick auf die Zeile unten), dann
hat man Einheiten von 10kB, was bei der Achse bis 100 einer maximal
sichtbaren Blockgrößen von 1MB entspricht.

Ein Blick ins Event Log, ob da eventuell SATA Übertragungsfehler drin
stehen, wäre auch kein Fehler.


Marcel
Shinji Ikari
2017-08-21 11:41:06 UTC
Permalink
Raw Message
Guten Tag
Post by Marcel Mueller
Post by Detlef Wirsing
Controller ist ein Intel C220 on Board mit AHCI.
Ich bin mit Intel nicht vertraut, aber ist das zufällig einer der Intel
SATA Controller, die sich nach einiger Zeit selbst desintegrieren? Von
den Symptomen her würde es passen.
Sofern ich mich nicht irre und richtig geucht habe:
Das damals so genannte SATAgate-Problem betraf die Generation Sandy
Bridge.
https://www.golem.de/1102/81175.html
Danach kam IvyBridge.
Die C220 Generation ist der Nachfolger und gehoert zur
Haswell-generation.
Detlef Wirsing
2017-08-21 13:58:52 UTC
Permalink
Raw Message
Post by Shinji Ikari
Das damals so genannte SATAgate-Problem betraf die Generation Sandy
Bridge.
https://www.golem.de/1102/81175.html
Danach kam IvyBridge.
Die C220 Generation ist der Nachfolger und gehoert zur
Haswell-generation.
Prozessor ist jedenfalls ein Haswell i5.

Ich bin inzwischen etwas weiter - oder auch nicht. Der Fehler scheint
nur zwei von insgesamt 7 Platten zu betreffen. Eine davon diente mir
kürzlich als Zwischenlager fürs Umkopieren und lief völlig unauffällig
bei voller Geschwindigkeit. Nach dem letzten Zustecken von 2 Platten
in meinen HTPC habe ich mich endlich durchgerungen, alle Platten in
meinen beiden PCs mit Veracrypt komplett zu verschlüsseln. Das hat bei
insgesamt 12 Platten und 3 SSDs mehrere Wochen gedauert, weil viel hin
und her geschoben und überprüft werden musste. Erst ganz zum Schluss
trat das Problem mit dem Einbruch bei der Übertragungsgeschwindigkeit
auf.

Die beiden Platten, die es haben, habe ich mit HD Tune getestet. Die
Performance beim Bechmark zeigt keine Auffälligkeiten, die Werte sind
identisch mit anderen eingebauten Platten der gleichen Serien.
Trotzdem geht nach 4-4,5 GB bei besagten zwei Platten der Transfer
reproduzierbar in den Keller.

Ich habe zwei Tage daran gesessen und die Ursache nicht gefunden.
Falls jemandem noch was dazu einfällt, probiere ich gern weiter. Aber
allzu viel Zeit werde ich nicht mehr investieren. Ich habe schon
einige Wochen einen neuen Controller hier, den ich nur deshalb noch
nicht einbauen kann, weil mein Rechner dafür umgebaut werden muss und
ich mir den Arm gebrochen habe.

Mit freundlichen Grüßen
Detlef Wirsing
Frank Möller
2017-08-21 19:57:39 UTC
Permalink
Raw Message
Nach dem letzten Zustecken von 2 Platten in meinen HTPC habe ich mich
endlich durchgerungen, alle Platten in meinen beiden PCs mit Veracrypt
komplett zu verschlüsseln.
Diese Zusatzinfo hätte eigentlich ins OP gehört, denn selbstverständlich
ist das etwas, was Platten ganz dramatisch einbremsen kann (aus welchen
Gründen auch immer).
Das hat bei insgesamt 12 Platten und 3 SSDs mehrere Wochen gedauert, weil
viel hin und her geschoben und überprüft werden musste. Erst ganz zum
Schluss trat das Problem mit dem Einbruch bei der
Übertragungsgeschwindigkeit auf.
Tja, SZ = Selbert Zschuld, hättest ja vorher mal fragen können. Dann
hättest Du schon erfahren, daß ich a) mit Diskcryptor
<https://diskcryptor.net/wiki/Main_Page/de> noch nie und auf keiner
Platte/SSD ein solch dramatisches Performance-Problem hatte, das Teil b)
OpenSource ist, es c) auch Win 8 und 8.1 unterstützt, es d)
Multi-Boot-Installationen (für Windows) unterstützt und es e) vor allem on
the Fly bei laufendem System und mit vorhandenen Daten verschlüsselt. Es
ist also keine wahnwitzige Backup- und Restore-Orgie nur für das
Verschlüsseln nötig.

VeraCrypt (vorher TrueCrypt) verwende ich nur für externe USB-Platten.
Die beiden Platten, die es haben, habe ich mit HD Tune getestet.
Das ist synthetischer Quark und völlig witz- und sinnlos, das bringt keine
belastbare Aussage. Wenn Du wissen willst, was los ist, mußt Du live
testen, z. B. mit Robocopy und mit genügend Dateien in entsprechender Größe
(in Summe deutlich größer als der System-Cache).

--
Detlef Wirsing
2017-08-22 06:52:11 UTC
Permalink
Raw Message
Post by Frank Möller
Nach dem letzten Zustecken von 2 Platten in meinen HTPC habe ich mich
endlich durchgerungen, alle Platten in meinen beiden PCs mit Veracrypt
komplett zu verschlüsseln.
Diese Zusatzinfo hätte eigentlich ins OP gehört, denn selbstverständlich
ist das etwas, was Platten ganz dramatisch einbremsen kann (aus welchen
Gründen auch immer).
Das fand ich nicht erwähnenswert, weil ich alle Platten identisch
verschlüsselt habe und der Datentransfer nach der Verschlüsselung mit
voller Geschwindigkeit und fehlerfrei ablief. Bis eben vor 2-3 Tagen.
Post by Frank Möller
Das hat bei insgesamt 12 Platten und 3 SSDs mehrere Wochen gedauert, weil
viel hin und her geschoben und überprüft werden musste. Erst ganz zum
Schluss trat das Problem mit dem Einbruch bei der
Übertragungsgeschwindigkeit auf.
Tja, SZ = Selbert Zschuld, hättest ja vorher mal fragen können. Dann
hättest Du schon erfahren, daß ich a) mit Diskcryptor
<https://diskcryptor.net/wiki/Main_Page/de> noch nie und auf keiner
Platte/SSD ein solch dramatisches Performance-Problem hatte, das Teil b)
OpenSource ist, es c) auch Win 8 und 8.1 unterstützt, es d)
Multi-Boot-Installationen (für Windows) unterstützt und es e) vor allem on
the Fly bei laufendem System und mit vorhandenen Daten verschlüsselt. Es
ist also keine wahnwitzige Backup- und Restore-Orgie nur für das
Verschlüsseln nötig.
Die Wahl des Verschlüsselungsprogramms geschah nach meinen
Bedürfnissen schon vor längerer Zeit. Bisher gab es damit nie
Probleme, und die Tatsache, dass über eine der jetzt langsamen Platten
20 TB Daten mit voller Geschwindigkeit gelaufen sind (schreiben und
lesen), lässt deine Vermutung, es könne an Veracrypt liegen,
zweifelhaft erscheinen.
Post by Frank Möller
VeraCrypt (vorher TrueCrypt) verwende ich nur für externe USB-Platten.
SZ. Dafür, dass du das Programm selbst benutzt, kennst du es ziemlich
schlecht, denn alle scheinbaren Vorzüge, die du oben aufführst,
besitzt auch Veracrypt. Dass ich nicht im Hintergrund habe
verschlüsseln lassen, war wahlfrei.
Post by Frank Möller
Die beiden Platten, die es haben, habe ich mit HD Tune getestet.
Das ist synthetischer Quark und völlig witz- und sinnlos, das bringt keine
belastbare Aussage. Wenn Du wissen willst, was los ist, mußt Du live
testen, z. B. mit Robocopy und mit genügend Dateien in entsprechender Größe
(in Summe deutlich größer als der System-Cache).
Womit man hin und her kopiert, dürfte in diesem Fall ziemlich egal
sein. Und mein System-Cache beträgt nicht mehrere TB. Ich dachte, das
wäre aus dem Thread klar geworden.

Mit freundlichen Grüßen
Detlef Wirsing
Frank Möller
2017-08-22 17:04:45 UTC
Permalink
Raw Message
Post by Detlef Wirsing
Post by Frank Möller
Nach dem letzten Zustecken von 2 Platten in meinen HTPC habe ich mich
endlich durchgerungen, alle Platten in meinen beiden PCs mit Veracrypt
komplett zu verschlüsseln.
Diese Zusatzinfo hätte eigentlich ins OP gehört, denn selbstverständlich
ist das etwas, was Platten ganz dramatisch einbremsen kann (aus welchen
Gründen auch immer).
Das fand ich nicht erwähnenswert, weil ich alle Platten identisch
verschlüsselt habe und der Datentransfer nach der Verschlüsselung mit
voller Geschwindigkeit und fehlerfrei ablief. Bis eben vor 2-3 Tagen.
Teste es nochmal unverschlüsselt, siehe Parallelposting.
Post by Detlef Wirsing
Post by Frank Möller
Das hat bei insgesamt 12 Platten und 3 SSDs mehrere Wochen gedauert, weil
viel hin und her geschoben und überprüft werden musste. Erst ganz zum
Schluss trat das Problem mit dem Einbruch bei der
Übertragungsgeschwindigkeit auf.
Tja, SZ = Selbert Zschuld, hättest ja vorher mal fragen können. Dann
hättest Du schon erfahren, daß ich a) mit Diskcryptor
<https://diskcryptor.net/wiki/Main_Page/de> noch nie und auf keiner
Platte/SSD ein solch dramatisches Performance-Problem hatte, das Teil b)
OpenSource ist, es c) auch Win 8 und 8.1 unterstützt, es d)
Multi-Boot-Installationen (für Windows) unterstützt und es e) vor allem on
the Fly bei laufendem System und mit vorhandenen Daten verschlüsselt. Es
ist also keine wahnwitzige Backup- und Restore-Orgie nur für das
Verschlüsseln nötig.
Die Wahl des Verschlüsselungsprogramms geschah nach meinen
Bedürfnissen schon vor längerer Zeit. Bisher gab es damit nie
Probleme, und die Tatsache, dass über eine der jetzt langsamen Platten
20 TB Daten mit voller Geschwindigkeit gelaufen sind (schreiben und
lesen), lässt deine Vermutung, es könne an Veracrypt liegen,
zweifelhaft erscheinen.
Hm, Pferde, Apotheke und so. Ich würde diesen Punkt auf jeden Fall sehr
genau und ausgiebig prüfen.
Post by Detlef Wirsing
Post by Frank Möller
VeraCrypt (vorher TrueCrypt) verwende ich nur für externe USB-Platten.
SZ. Dafür, dass du das Programm selbst benutzt, kennst du es ziemlich
schlecht, denn alle scheinbaren Vorzüge, die du oben aufführst,
besitzt auch Veracrypt. Dass ich nicht im Hintergrund habe
verschlüsseln lassen, war wahlfrei.
Die o. g. Vorzüge von DiskCryptor sind nicht "scheinbar", sondern
tatsächlich vorhanden. Wenn VeraCrypt das (mittlerweile) auch alles kann,
ist das ja nur gut.
Post by Detlef Wirsing
Post by Frank Möller
Die beiden Platten, die es haben, habe ich mit HD Tune getestet.
Das ist synthetischer Quark und völlig witz- und sinnlos, das bringt keine
belastbare Aussage. Wenn Du wissen willst, was los ist, mußt Du live
testen, z. B. mit Robocopy und mit genügend Dateien in entsprechender Größe
(in Summe deutlich größer als der System-Cache).
Womit man hin und her kopiert, dürfte in diesem Fall ziemlich egal
sein. ...
.. nur daß HD Tune nichts tut, was man als Live-Kopieren bezeichnen könnte.

--
Detlef Wirsing
2017-08-22 18:35:49 UTC
Permalink
Raw Message
[...]
Post by Frank Möller
Post by Detlef Wirsing
Womit man hin und her kopiert, dürfte in diesem Fall ziemlich egal
sein. ...
.. nur daß HD Tune nichts tut, was man als Live-Kopieren bezeichnen könnte.
Natürlich nicht, da es nicht schreibt. Ich hatte es offen, um die
Smart-Werte der beiden langsamen Platten zu überprüfen. Bei der
Gelegenheit habe ich die Lesebenchmarks meiner Platten verglichen.
Dass bei Zweien was im Argen liegt, wusste ich ja schon.

Ein seltsamer Fehler, so oder so. Ich habe irgendwie ein Händchen für
Probleme, die sonst niemand hat, oder auch 2-3 gleichzeitig
auftretende Fehler, die eine Lokalisierung fast unmöglich machen.

Wie auch immer: Ich lasse die Sache jetzt so, wie sie ist. Mit etwas
Glück verschwindet der Fehler nach dem lange geplanten Umbau in 2-3
Wochen. Falls nicht, muss ich eben nochmal ran.

Mit freundlichen Grüßen
Detlef Wirsing
Peter Koerber
2017-08-22 20:30:23 UTC
Permalink
Raw Message
Post by Detlef Wirsing
Natürlich nicht, da es nicht schreibt. Ich hatte es offen, um die
Smart-Werte der beiden langsamen Platten zu überprüfen. Bei der
Gelegenheit habe ich die Lesebenchmarks meiner Platten verglichen.
Dass bei Zweien was im Argen liegt, wusste ich ja schon.
Ähm tschuldigung, habe ich richtig verstanden, dass der Fehler bei zwei
verschiedenen angehängten Festplatten stattfindet? Und würde der Fehler
auch noch bei einer dritten Festplatte stattfinden?
Dann wäre es spätestens Zeit, mal die Quellfestplatte näher zu untersuchen!
Peter
Detlef Wirsing
2017-08-23 06:13:17 UTC
Permalink
Raw Message
Post by Peter Koerber
Ähm tschuldigung, habe ich richtig verstanden, dass der Fehler bei zwei
verschiedenen angehängten Festplatten stattfindet? Und würde der Fehler
auch noch bei einer dritten Festplatte stattfinden?
Dann wäre es spätestens Zeit, mal die Quellfestplatte näher zu untersuchen!
Peter
Es geht um insgesamt 14 Festplatten und 3 SSDs. Mit Sicherheit habe
ich nicht jede mögliche Quell-Ziel-Kombination getestet, das wären 182
Stück, wenn man die SSDs außer Acht lässt, bin aber im Moment auf dem
Stand, dass "nur" zwei Platten an einem PC besagte Probleme bereiten.

Mit freundlichen Grüßen
Detlef Wirsing
Thorsten Albrecht
2017-08-23 11:44:50 UTC
Permalink
Raw Message
Post by Detlef Wirsing
Das fand ich nicht erwähnenswert, weil ich alle Platten identisch
verschlüsselt habe ...
Du hattest ja schon mehrfach hier erwähnt, dass Du mit Deinen vielen
Festplatten hauptsächlich Videos verwaltest. Gibt es einen Grund,
warum Du es Dir plötzlich nach vielen Jahren angetan hast, Dein
gesamtes Videoarchiv zu verschlüsseln? Soll die Nachwelt nichts mehr
von Deiner Videosammlung haben? Bei 14 Festplatten muss das ja eine
fast nicht endende Kopierarie gewesen sein, OMG. Auf jeden Fall war
das ein guter Hardwaretest...

Thorsten
Lothar Planitzer
2017-08-25 10:38:54 UTC
Permalink
Raw Message
Post by Thorsten Albrecht
[...]
Du hattest ja schon mehrfach hier erwähnt, dass Du mit Deinen vielen
Festplatten hauptsächlich Videos verwaltest. Gibt es einen Grund,
warum Du es Dir plötzlich nach vielen Jahren angetan hast, Dein
gesamtes Videoarchiv zu verschlüsseln?
Das wüsste ich allerdings auch mal gerne...


Gruß Lothar
Detlef Wirsing
2017-08-25 11:41:36 UTC
Permalink
Raw Message
Post by Lothar Planitzer
Post by Thorsten Albrecht
[...]
Du hattest ja schon mehrfach hier erwähnt, dass Du mit Deinen vielen
Festplatten hauptsächlich Videos verwaltest. Gibt es einen Grund,
warum Du es Dir plötzlich nach vielen Jahren angetan hast, Dein
gesamtes Videoarchiv zu verschlüsseln?
Das wüsste ich allerdings auch mal gerne...
Von mir wird keine Antwort kommen. Es hat mit dem hier geschilderten
Problem nichts zu tun und geht niemanden was an.

Mit freundlichen Grüßen
Detlef Wirsing
Frank Möller
2017-08-25 11:48:30 UTC
Permalink
Raw Message
Post by Lothar Planitzer
Post by Thorsten Albrecht
[...]
Du hattest ja schon mehrfach hier erwähnt, dass Du mit Deinen vielen
Festplatten hauptsächlich Videos verwaltest. Gibt es einen Grund,
warum Du es Dir plötzlich nach vielen Jahren angetan hast, Dein
gesamtes Videoarchiv zu verschlüsseln?
Das wüsste ich allerdings auch mal gerne...
Wenn man seine Daten sowieso verschlüsselt, wieso nicht einfach alles und
somit auch Videos? Es tut nicht weh und ist einfach ganz automagisch eine
Baustelle weniger.

Z. B. im Defektfall muß man sich nicht erst fragen, ob da vielleicht doch
mal irgendwann schützenswerte Daten hinkopiert oder zwischengelagert
wurden, von denen man nicht so genau weiß, ob deren Position bereits
anderweitig überschrieben wurde. Solche Unklarheiten gibt's dann halt
einfach nicht.

--
Shinji Ikari
2017-08-22 07:47:50 UTC
Permalink
Raw Message
Guten Tag
Post by Detlef Wirsing
Nach dem letzten Zustecken von 2 Platten
in meinen HTPC habe ich mich endlich durchgerungen, alle Platten in
meinen beiden PCs mit Veracrypt komplett zu verschlüsseln.
Verstehe ich das richtig, das Problem hast Du zuerst bemerkt, direkt
nachdem alles mit VC verschluesselt wurde?
Wenn ja, wuerde ich zumindest in der Richtung die Bremse suchen.
Post by Detlef Wirsing
und
ich mir den Arm gebrochen habe.
Gute Besserung und schnelle Genesung!
Detlef Wirsing
2017-08-22 08:30:22 UTC
Permalink
Raw Message
Post by Shinji Ikari
Guten Tag
Post by Detlef Wirsing
Nach dem letzten Zustecken von 2 Platten
in meinen HTPC habe ich mich endlich durchgerungen, alle Platten in
meinen beiden PCs mit Veracrypt komplett zu verschlüsseln.
Verstehe ich das richtig, das Problem hast Du zuerst bemerkt, direkt
nachdem alles mit VC verschluesselt wurde?
Wenn ja, wuerde ich zumindest in der Richtung die Bremse suchen.
Ich habe nach und nach die Inhalte aller Datenplatten verschoben,
jeweils eine freigewordene Platte verschlüsselt und diese wieder mit
Daten gefüllt. Als Zwischenlager diente dabei vor allem eine der jetzt
langsamen Platten. Von dieser kopierte ich ingesamt mindestens 20 TB
auf frisch verschlüsselte Platten. All das lief völlig normal ab, auch
die Überprüfungen mittels MD5-Checksummen. Erst bei der Übertragung
des letzten Verzeichnisses knickte die Übertragungsrate nach ca. 4,5
GB auf ein Sechstel ein. Also probierte ich es mit einer anderen
Platte mit demselben Ergebnis. Ich ging von einem Treiberproblem des
Controllers aus und schrieb dir privat.

Im Laufe weiterer Tests bemerkte ich, dass anscheinend nur zwei
Platten betroffen sind, welche die ganze Zeit fehlerfrei
funktionierten und zuerst von mir verschlüsselt worden waren - mit
denselben Werten wie alle anderen. Ein Problem mit der Verschlüsselung
könnte natürlich trotzdem vorliegen. Dann bliebe aber die Frage, warum
es vorher so lange nicht in Erscheinung trat. Bei einer Platte würde
ich auf Hardwareschaden tippen, z.B. defekter Plattencache. Aber zwei
gleichzeitige identische Plattenschäden trotz weiterer Platten, die am
selben Controller mit identischer Verschlüsselung fehlerfrei
funktionieren, sind äußerst unwahrscheinlich.
Post by Shinji Ikari
Post by Detlef Wirsing
und
ich mir den Arm gebrochen habe.
Gute Besserung und schnelle Genesung!
Wird schon, danke. Ist nur ein ungünstiger Zeitpunkt. Unter anderem
liegt hier seit Wochen eine verpackte neue Matratze rum, die ich
längst ausgetauscht haben wollte. Nur mit Links schaffe ich es aber
nicht einmal, sie auszupacken. Vom schon länger geplanten Umbau meines
"Arbeitsrechners" mal ganz abgesehen.

Mit freundlichen Grüßen
Detlef Wirsing
Frank Möller
2017-08-22 17:04:46 UTC
Permalink
Raw Message
Post by Detlef Wirsing
Ich habe nach und nach die Inhalte aller Datenplatten verschoben,
jeweils eine freigewordene Platte verschlüsselt und diese wieder mit
Daten gefüllt. Als Zwischenlager diente dabei vor allem eine der jetzt
langsamen Platten. Von dieser kopierte ich ingesamt mindestens 20 TB
auf frisch verschlüsselte Platten. All das lief völlig normal ab, auch
die Überprüfungen mittels MD5-Checksummen. Erst bei der Übertragung
des letzten Verzeichnisses knickte die Übertragungsrate nach ca. 4,5
GB auf ein Sechstel ein. Also probierte ich es mit einer anderen
Platte mit demselben Ergebnis. Ich ging von einem Treiberproblem des
Controllers aus und schrieb dir privat.
Im Laufe weiterer Tests bemerkte ich, dass anscheinend nur zwei
Platten betroffen sind, welche die ganze Zeit fehlerfrei
funktionierten und zuerst von mir verschlüsselt worden waren - mit
denselben Werten wie alle anderen. Ein Problem mit der Verschlüsselung
könnte natürlich trotzdem vorliegen. ...
Ich würde systematisch vorgehen und zunächst nur eines machen: Eine der
betreffenden Platten unverschlüsselt formatieren und dann sehr ausgiebig
mit Kopiertests aller Couleur prüfen.

Geht sie dann auch nicht, kannst Du die Verschlüsselung als Übeltäter
zumindest recht sicher ausschließen.

Geht sie dann jedoch wieder, scheint sie - weiß der Geier, warum - mit der
Verschlüsselung halt irgendwie nicht klarzukommen.

Mehr als Trial & Error und Schritt für Schritt sehe ich momentan nicht.

--
Detlef Wirsing
2017-08-22 18:40:00 UTC
Permalink
Raw Message
Frank Möller schrieb:

[...]
Post by Frank Möller
Mehr als Trial & Error und Schritt für Schritt sehe ich momentan nicht.
Das sehe ich auch so, werde aber durch den Austausch des Controllers
und der Kabel mehrere Schritte auf einmal machen, bevor ich weiter
nach der Ursache suche. Früher (tm) wollte ich immer alles genau
wissen. Heute interessiert mich nur noch, dass der Scheiß rennt.

Mit freundlichen Grüßen
Detlef Wirsing
Frank Möller
2017-08-23 08:41:13 UTC
Permalink
Raw Message
Post by Detlef Wirsing
Post by Frank Möller
Mehr als Trial & Error und Schritt für Schritt sehe ich momentan nicht.
Das sehe ich auch so, werde aber durch den Austausch des Controllers
und der Kabel mehrere Schritte auf einmal machen, bevor ich weiter
nach der Ursache suche. Früher (tm) wollte ich immer alles genau
wissen. Heute interessiert mich nur noch, dass der Scheiß rennt.
Ich würde unabhängig von dem Umbau und vor allem davor empfehlen, die
besagten zwei Platten nochmal unverschlüsselt zu testen, zumal Du ja 14
HDDs und 3 SSDs betreibst.

Es gab in der Vergangenheit mit dieser und jener Verschlüsselungs-Software
durchaus Probleme bei zahlreichen verschlüsselten Volumes im gleichzeitigen
Betrieb. Schon deswegen würde ich dem Phänomen nachgehen wollen. Aber
zwingen kann Dich natürlich niemand. ;->

--
Thorsten Albrecht
2017-08-23 11:33:44 UTC
Permalink
Raw Message
Post by Detlef Wirsing
Das sehe ich auch so, werde aber durch den Austausch des Controllers
und der Kabel mehrere Schritte auf einmal machen, bevor ich weiter
nach der Ursache suche.
Wieso sollte denn der Controller nur bei 2 Festplatten versagen,
während er bei Deinen ganzen anderen Festplatten normal funktioniert?
Der ist sicherlich in Ordnung.

Überprüfe die Platten an einem zweiten Rechner, das ist definitiv das
Erste, was man tun muss. Falls es dort auch den selben
Performanceeinbruch gibt, dann ist die Sache klar.

Was ich auch machen würde: Kurz eine frisches OS starten und gucken,
ob dort der Fehler ebenfalls auftritt. Irgendeine kleine Reserveplatte
wirst Du ja wohl haben, um kurz mal Win10 o.ä. drauf zu spielen.

Thorsten
Thomas Niering
2017-08-21 04:33:00 UTC
Permalink
Raw Message
Hallo Detlef,
Post by Detlef Wirsing
Ab da habe ich statt der sonst üblichen 110 MB/s nur noch
gleichbleibende 18. Das verwundert mich vor allem deshalb, weil ich
gerade erst ca. 20 TB an Daten bei voller Geschwindigkeit verschoben
habe.
Da spielen mehrere Faktoren eine Rolle.
Angefangen von der Anzahl/Größe der zu kopierenden Daten über die
beteiligten Festplatten bis hin zum Dateisystem und der Fragmentierung.

Ciao Thomas
Detlef Wirsing
2017-08-21 07:17:40 UTC
Permalink
Raw Message
Post by Thomas Niering
Hallo Detlef,
Post by Detlef Wirsing
Ab da habe ich statt der sonst üblichen 110 MB/s nur noch
gleichbleibende 18. Das verwundert mich vor allem deshalb, weil ich
gerade erst ca. 20 TB an Daten bei voller Geschwindigkeit verschoben
habe.
Da spielen mehrere Faktoren eine Rolle.
Angefangen von der Anzahl/Größe der zu kopierenden Daten über die
beteiligten Festplatten bis hin zum Dateisystem und der Fragmentierung.
Das ist mir schon klar, aber wenn die Übertragungsgeschwindigkeit von
einem auf den anderen Tag um 84% einbricht, liegt das nicht an den
Dateien, die übrigens eher groß sind.

Mit freundlichen Grüßen
Detlef Wirsing
Armin Wolf
2017-08-22 04:51:01 UTC
Permalink
Raw Message
Post by Detlef Wirsing
seit 2 Tagen bricht bei mir die Kopiergeschwindigkeit von Platte zu
Platte nach ca. 4 GB ein. Das ist der Wert, in dem der Cache noch
greift.
Funktionierte diese Platte mit dieser Partitionseinstellung
schon einmal schneller?

Nein? Alignement verkehrt...
Nutze "Minitool" um dieses zu justieren.

Ich habe hier eine ähnliche Platte liegen, wo es eindeutig
ein Hardware- defekt ist...
Detlef Wirsing
2017-08-22 07:02:24 UTC
Permalink
Raw Message
Post by Armin Wolf
Post by Detlef Wirsing
seit 2 Tagen bricht bei mir die Kopiergeschwindigkeit von Platte zu
Platte nach ca. 4 GB ein. Das ist der Wert, in dem der Cache noch
greift.
Funktionierte diese Platte mit dieser Partitionseinstellung
schon einmal schneller?
Ja, bis eben der Fehler auftrat und auch sofort auffiel. Man merkt auf
Anhieb, wenn das Kopieren eines Verzeichnisses nicht mehr 5, sondern
30 Stunden dauert.
Post by Armin Wolf
Nein? Alignement verkehrt...
Nutze "Minitool" um dieses zu justieren.
Ich habe hier eine ähnliche Platte liegen, wo es eindeutig
ein Hardware- defekt ist...
Bei mir betrifft es zwei Platten, wie sich inzwischen herausgestellt
hat. Bei einer würde ich auch auf einen Hardwaredefekt tippen. Aber
zwei Platten, die plötzlich genau gleichzeitig denselben
Hardwareschaden haben? Das ist unwahrscheinlich.

Mit freundlichen Grüßen
Detlef Wirsing
Marcel Mueller
2017-08-25 17:31:35 UTC
Permalink
Raw Message
Post by Detlef Wirsing
Bei mir betrifft es zwei Platten, wie sich inzwischen herausgestellt
hat. Bei einer würde ich auch auf einen Hardwaredefekt tippen. Aber
zwei Platten, die plötzlich genau gleichzeitig denselben
Hardwareschaden haben? Das ist unwahrscheinlich.
Ich hatte schon 2 (baugleiche) SCSI-Platten, die nach Jahren Betrieb
innerhalb weniger Tage ausgefallen sind. War noch Garantie drauf, also
beide eingeschickt, sofort ersetzt, und die Ersatzplatten mit
Restgarantie ungeöffnet weiterverkauft.

Ich hatte auch schon 3 defekte ATX-Netzteile an einem Tag.
(Unterschiedliche Rechner und Fabrikate)

Also nie die Sache mit den Pferden und er Apotheke vergessen...


Marcel
Marcel Mueller
2017-08-25 17:38:10 UTC
Permalink
Raw Message
Post by Detlef Wirsing
seit 2 Tagen bricht bei mir die Kopiergeschwindigkeit von Platte zu
Platte nach ca. 4 GB ein. Das ist der Wert, in dem der Cache noch
greift. Ab da habe ich statt der sonst üblichen 110 MB/s nur noch
gleichbleibende 18. Das verwundert mich vor allem deshalb, weil ich
gerade erst ca. 20 TB an Daten bei voller Geschwindigkeit verschoben
habe.
Eine Idee fällt mir gerade noch ein. Du schriebst Doch etwas von genau 2
Platten. - Vibrationen

Es kann manchmal vorkommen, dass sich Vibrationen von einer Platte über
das Gehäuse auf eine andere übertragen. Das kann die
Positioniergenauigkeit der Schreib-Lese-Köpfe stark negativ
beeinflussen. Symptom wäre eine geringere Netto-Geschwindigkeit.
Aufgrund der unterschiedlichen Einbausituation und aufgrund leicht
unterschiedlicher Drehzahlen kann das durchaus nur einzelne Platten
betreffen. Typischerweise sind gleiche Modelle anfälliger dafür als ein
bunter Blumenstrauß.

Wie gesagt, ist nur so eine Idee.


Marcel
Detlef Wirsing
2017-08-26 07:29:34 UTC
Permalink
Raw Message
Post by Marcel Mueller
Eine Idee fällt mir gerade noch ein. Du schriebst Doch etwas von genau 2
Platten. - Vibrationen
Auch das ist unwahrscheinlich, und zwar aus zwei Gründen. Erstens ist
das Gehäuse sehr stabil (Lian Li PC-A75X), die Platten von WD mit
Gummipuffern versehen und extrem laufruhig. Zweitens schalten die
Platten einzeln nach 10 Minuten Nichtbenutzung ab. Spätestens nach
dieser Zeit sind nur noch Quell- und Zielplatte in Betrieb.

Mit freundlichen Grüßen
Detlef Wirsing

Loading...